Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 11, 2026 - 23:30 UTC
Scheduled
Scheduled maintenance will be performed on the network insfrastructure to improve overall performance and user experience.
During this maintenance window, the web application may be temporarily unavailable. We apologize for any inconvenience and appreciate your understanding.
Posted Sep 03, 2026 - 05:22 UTC
This scheduled maintenance affected: Straatos - Europe.